设为首页 收藏本站

运维网

查看: 219|回复: 4

cisco 与华为 MPLS VPN配置案例

[复制链接]

累计签到:68 天
连续签到:1 天
发表于 2017-9-23 09:29:11 | 显示全部楼层 |阅读模式
cisco
MPLS VPN
1.配置PE-P-PE之间的IGP以保证它们的联通性,配置IGP的目的仅仅是为了保证在建立iBGP时邻居的可达性
2.启用PE-P-PE相连接口的LDP以及MPLS功能(需要注意的是MPLS功能需要CEF的支持,默认已经开启)
PE(config)#int s0/0
PE(config-if)#mpls ip
PE(config-if)#mpls mtu 1508     #更改接口MTU值。需要在PE与P互联的所有接口上配置。

3.在PE上定义并配置VRF参数

PE(config)#ip vrf vrf_name
     #用于标示用户VPN实例,每个vrf_name必须保证唯一。在理解vrf时我们  可以把它看做每个vrf是由一台虚拟的

路由器来单独维护一张vrf路由表。注意区分vrf_name的大小写。

PE(config-vrf)#rd ASN:nn/IP-address:nn
     #用来区分不同VRF中相同地址段,也就是解决地址空间 重叠的问题。通常建议配置基于VRF的RD,而不是基于

VPN的RD。

PE(config-vrf)#router-target [both/export/import] [ASN:nn/IP-address:nn]
     #它是BGP的一个扩展团体属性,格式同RD。用来表示该VRF路由表接收和发送路由的意愿(import 表示接收意愿

;export 表示发送意愿。如果某个VRF同时存在两条 以上import或export则它们之间是“或”的关系。

4.将VRF与相应的接口进行关联(PE与CE相连接的接口)
PE(config)#int s0/0
PE(config-if)#ip vrf forwarding vrf_name
PE(config-if)#ip add x.x.x.x y.y.y.y #接口和VRF关联后会删除这个接口的IP地址,需要重新配置接口的IP地址
5.配置PE到PE的iBGP连接(MP-BGP)
PE (config)#router bgp 100
PE(config-router)#bgp router-id 2.2.2.2
PE(config-router)#no bgp default ipv4-unicast     #禁止BGP全局下的ipv4-unicast路由交换。配置之后设备之

间将不在交换路由(公共网络的数据交换通过MPLS来达成)。通过address-family子模式可以激活基于vpn的bgp邻居

PE(config-router)#nei 4.4.4.4 remote-as 100
PE(config-router)#nei 4.4.4.4 update-source lo0
PE(config-router)#no auto-summary
↑↑↑配置BGP普通邻居关系

PE(config-router)#address-family ipv4     #进入ipv4配置子模式
PE(config-router-af)#no neighbor 10.10.10.2 activate     #默认配置了neighbor命令会激活ipv4邻居
PE(config-router-af)#exit-address-family
↑↑↑禁止对等体之间建立ipv4邻居关系(视具体情况进行配置)

PE(config-router)#address-family vpnv4      #进入vpnv4配置子模式
PE(config-router-af)#nei 4.4.4.4 activate     #激活vpnv4地址族iBGP邻居
PE(config-router-af)#nei 4.4.4.4 send-community extended   #Cisco路由器默认发送扩展的团体属性,这个配置

可省略
PE(config-router-af)#exit-address-family
↑↑↑激活vpnv4邻居关系

6.配置PE与CE间的vrf 路由 (注意这里与传统路由的区别)
a)PE端配置
PE(config)#router bgp 100
PE(config-router)#bgp router-id 1.1.1.1
PE(config-router)#address-family ipv4 vrf vpn1
PE(config-router-af)#neighbor 14.1.1.2 remote-as 200   #与CE端使用直连接口建立ipv4 vrf vpn1的邻居关系
PE(config-router-af)#neighbor 14.1.1.2 activate
↑↑↑不需要进行重分发操作。MP-BGP会自动将从对端PE(通过iBGP)学习到的vpn路由通告给CE端(通过eBGP)
b)CE端配置
CE(config)#router bgp 200
CE(config-router)#bgp router-id 2.2.2.2
CE(config-router)#neighbor 14.1.1.1 remote-as 100
CE(config-router)#network 10.1.1.0 mask 255.255.255.0


华为:
①配置各路由器接口以及PE-P-PE内部IGP,保证用于建立iBGP邻居的各路由器环回接口的可达性
PE1(config)#router isis
PE1(config-router)#net 49.0000.0000.0001.00
PE1(config-router)#int f0/0
PE1(config-if)#ip router isis
PE1(config-if)#int lo0
PE1(config-if)#ip router isis   #只启用PE-P对接接口的ISIS路由功能,但是不要忽略了环回接口也需要启用
PE1(config-router)#is-type level-1  #优化ISIS配置,使路由器 只发送level-1 Hello(只维护level-1 LSDB)
P、PE2:配置同PE1。基本的接口配置省略。
②启用PE-P-PE各个相连接口的MPLS功能
P(config)#int f1/0
P(config-if)#mpls ip
P(config-if)#exit
P(config-if)#int f2/0
P(config-if)#mpls ip
PE1、PE2:配置同P基本相同
③在PE上定义并配置VRF参数
PE1(config)#ip vrf vpna
PE1(config-vrf)#rd 100:1
PE1(config-vrf)#route-target import 100:1
PE1(config-vrf)#route-target export 100:1
PE1(config-vrf)#exit
PE1(config)#ip vrf vpnb
PE1(config-vrf)#rd 200:2
PE1(config-vrf)#route-target import 200:2
PE1(config-vrf)#route-target export 200:2
PE2:配置同PE1
④将VRF与相应的接口进行关联(PE与CE相连接的接口)
PE1(config-vrf)#int f2/0
PE1(config-if)#ip vrf forwarding vpna
% Interface FastEthernet2/0 IP address 14.1.1.1 removed due to enabling VRF vpna
PE1(config-if)#ip add 14.1.1.1 255.255.255.252
PE1(config-if)#int f1/0
PE1(config-if)#ip vrf forwarding vpnb
% Interface FastEthernet1/0 IP address 15.1.1.1 removed due to enabling VRF vpnb
PE1(config-if)#ip add 15.1.1.1 255.255.255.252
PE2:配置基本同PE1。
⑤配置PE到PE的iBGP连接(MP-BGP)
PE1(config)#router bgp 100
PE1(config-router)#bgp router-id 1.1.1.1
PE1(config-router)#nei 3.3.3.3 remote-as 100
PE1(config-router)#nei 3.3.3.3 update-source lo0
PE1(config-router)#address-family vpnv4
PE1(config-router-af)#nei 3.3.3.3 activate
PE1(config-router)#address-family ipv4 vrf vpna
PE1(config-router)#address-family ipv4 vrf vpnb
PE2:配置基本同PE1。
⑥配置PE到CE 的vrf 路由(注意这里与传统路由的区别)
a)静态路由
PE1(config)#ip route vrf vpna 10.1.1.1 255.255.255.255 14.1.1.2
PE1(config)#ip route vrf vpnb 10.1.1.1 255.255.255.255 15.1.1.2
PE1(config)#router bgp 100
PE1(config-router)#address-family ipv4 vrf vpna
PE1(config-router-af)#redistribute static
PE1(config-router-af)#exit-address-family
PE1(config-router)#address-family ipv4 vrf vpnb
PE1(config-router-af)#redistribute static
PE2:配置基本同PE1。
CE1_vpna(config)#ip route 0.0.0.0 0.0.0.0 14.1.1.1
CE1_vpnb、 CE2_vpna 、CE2_vpnb:配置都是只需要添加一条缺省路由指向对端的PE设备。
b)OSPF
PE1(config)#router ospf 1 vrf vpnb
PE1(config-router)#router-id 1.1.1.1
PE1(config-router)#redistribute bgp 100 subnets
PE1(config-router)#network 15.1.1.1 0.0.0.0 area 0
PE1(config-router)#exit
PE1(config)#router bgp 100
PE1(config-router)#address-family ipv4 vrf vpnb
PE1(config-router-af)#redistribute ospf 1
PE2:配置基本同PE1。
CE1_vpnb(config)#router ospf 1
CE1_vpnb(config-router)#router-id 10.1.1.1
CE1_vpnb(config-router)#net 10.1.1.1 0.0.0.0 a 0
CE1_vpnb(config-router)#net 15.1.1.2 0.0.0.0 a 0
CE1_vpna、 CE2_vpna 、CE2_vpnb:配置基本同CE1_vpnb。
c)BGP
PE1(config-router)#address-family ipv4 vrf vpnb
PE1(config-router-af)#neighbor 15.1.1.2 remote-as 500
PE1(config-router-af)#neighbor 15.1.1.2 activate
PE2:配置基本同PE1。
CE1_vpnb(config-router)#router bgp 500
CE1_vpnb(config-router)#nei 15.1.1.1 remote-as 100
CE1_vpnb(config-router)#network 10.1.1.1 mask 255.255.255.255
CE1_vpnb(config-router)#network 15.1.1.0 mask 255.255.255.252
CE1_vpna、 CE2_vpna 、CE2_vpnb:配置基本同CE1_vpnb

运维网声明 1、欢迎大家加入本站运维交流群:群①:263444886群②:197202523群③:485755530群④:201730672群⑤:202807635运维网交流群⑥:281548029
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、其他单位或个人使用、转载或引用本文时必须注明原文的出处
4、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意
5、运维网 - 服务您的运维操作管理专家!
6、联系人Email:[email protected] 网址:www.iyunv.com

点击关注更多内容

累计签到:3 天
连续签到:1 天
发表于 2017-9-23 22:34:22 | 显示全部楼层
满满的干活!满满的干活!满满的干活!满满的干活!满满的干活!满满的干活!

运维网声明 1、欢迎大家加入本站运维交流群:群①:263444886群②:197202523群③:485755530群④:201730672群⑤:202807635运维网交流群⑥:281548029
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、其他单位或个人使用、转载或引用本文时必须注明原文的出处
4、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意
5、运维网 - 服务您的运维操作管理专家!
6、联系人Email:[email protected] 网址:www.iyunv.com

您需要登录后才可以回帖 登录 | 立即注册  

本版积分规则  允许回帖邮件提醒楼主

关注运维网官方微信X

关注运维网官方微信

扫描二维码关注运维网官方微信,最新一手资源尽在官方微信!快快关注我们吧...

扫描微信二维码查看详情

客服 E-mail:[email protected]

本站由安畅网络和青云提供云计算服务

运维网--中国最专业的运维工程师交流社区

京ICP备14039699号-1 Copyright © 2012-2017

使用手机软件扫描微信二维码

关注我们可获取更多热点资讯

Good good study day day up !


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


合作伙伴: 青云cloud 安畅网络

快速回复 返回顶部 返回列表