设为首页 收藏本站

运维网

查看: 347|回复: 0

[经验分享] Cisco网络设备搭建***服务器的全部过程

[复制链接]

尚未签到

发表于 2018-7-12 08:54:40 | 显示全部楼层 |阅读模式
crypto isakmp policy 1 生成iskamp policy number 1  encryption des 选择用DES encryption也可用3DES指定三倍DES加密
  hash sha 指定使用的散列算法,也可以是md5(二端保持一致)
  authentication pre-share
  group 1 指定为Diffie-Hellman组,1表示768位,2表示1024位
  lifetime 14400 指定安全关联的有效期,不设就为默认值
  ------以下配置密钥方法-----

  crypto isakmp>  crypto isakmp key 654321 address 202.102.1.6 对远程路由器端口202.102.1.6使用密钥654321
  crypto isakmp key 654321 address 192.168.1.2 对远程路由器隧道端口192.168.1.2使用密钥654321
  !
  ------以下定义一个转换集-----
  crypto ipsec transform-set tset1 ah-md5-hmac esp-des esp-md5-hmac 可以定义一个或多个集
  !
  !
  -------以下建立加密图------
  crypto map cmap1 local-address serial 0 定义加密图cmap1并指定s0为本地地址
  crypto map cmap1 1 ipsec-isakmp 用序号1设置加密图
  set peer 202.102.1.6 设定目标地址
  set peer 192.168.1.2
  set transform-set test1 指定转换集
  match address 111 指定加密访问列表111中的地址
  !
  !
  process-max-time 200
  !
  -------以下设置隧道端口------
  interface Tunnel0
  ip address 192.168.1.1 255.255.255.0
  tunnel source 202.102.1.5
  tunnel destination 202.102.1.6
  crypto map cmap
  !
  -------以下设置内网口------
  interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
  !
  -------以下设置外网口------
  interface serial0
  ip address 202.102.1.5 255.255.255.0
  no ip mroute-cache
  no fair-queue
  crypto map cmap
  !

  ip>  !
  -------以下建立访问列表111------
  access-list 111 permit ip host 202.102.1.5 host 202.102.1.6
  access-list 111 permit ip host 202.102.1.6 host 202.102.1.5
  access-list 111 permit ip 10.1.1.0 0.0.0.255 202.102.1.0 0.0.0.255
  access-list 111 permit ip 10.1.2.0 0.0.0.255 202.102.1.0 0.0.0.255
  access-list 111 permit ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
  access-list 111 permit ip 10.1.2.0 0.0.0.255 10.1.1.0 0.0.0.255
  !
  line con 0
  line aux 0
  line vty 0 4
  password cisco
  login
  !
  end
  !
  上海路由器配置
  !
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname shanghai
  !
  enable cisco
  !
  !
  !------以下配置加密--------
  crypto isakmp policy 1 生成iskamp policy number 1
  encryption des 选择用DES encryption也可用3DES指定三倍DES加密
  hash sha 指定使用的散列算法,也可以是md5(二端保持一致)
  authentication pre-share
  group 1 指定为Diffie-Hellman组,1表示768位,2表示1024位
  lifetime 14400 指定安全关联的有效期,不设就为默认值
  ------以下配置密钥方法-----

  crypto isakmp>  crypto isakmp key 654321 address 202.102.1.5 对远程路由器端口202.102.1.6使用密钥654321
  crypto isakmp key 654321 address 202.102.1.6 对远程路由器端口202.102.1.6使用密钥654321
  crypto isakmp key 654321 address 192.168.1.1 对远程路由器隧道端口192.168.1.2使用密钥654321
  !
  ------以下定义一个转换集-----
  crypto ipsec transform-set tset1 ah-md5-hmac esp-des esp-md5-hmac 可以定义一个或多个集
  !
  !
  -------以下建立加密图------
  crypto map cmap1 local-address serial 0 定义加密图cmap1并指定s0为本地地址
  crypto map cmap1 1 ipsec-isakmp 用序号1设置加密图
  set peer 202.102.1.5 设定目标地址
  set peer 202.102.1.6
  set peer 192.168.1.1
  set transform-set test1 指定转换集
  match address 111 指定加密访问列表111中的地址
  !
  !
  process-max-time 200
  !
  -------以下设置隧道端口------
  interface Tunnel0
  ip address 192.168.1.2 255.255.255.0
  tunnel source 202.102.1.6
  tunnel destination 202.102.1.5
  crypto map cmap
  !
  -------以下设置内网口------
  interface Ethernet0
  ip address 10.1.2.1 255.255.255.0
  !
  -------以下设置外网口------
  interface serial0
  ip address 202.102.1.6 255.255.255.0
  no ip mroute-cache
  no fair-queue
  crypto map cmap
  !

  ip>  !
  -------以下建立访问列表111------
  access-list 111 permit ip host 202.102.1.5 host 202.102.1.6
  access-list 111 permit ip host 202.102.1.6 host 202.102.1.5

运维网声明 1、欢迎大家加入本站运维交流群:群①:263444886群②:197202523群③:485755530群④:201730672群⑤:202807635运维网交流群⑥:281548029
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、其他单位或个人使用、转载或引用本文时必须注明原文的出处
4、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意
5、运维网 - 服务您的运维操作管理专家!
6、联系人Email:admin@yunvn.com 网址:www.iyunv.com

点击关注更多内容
您需要登录后才可以回帖 登录 | 立即注册  

本版积分规则  允许回帖邮件提醒楼主

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服 E-mail:kefu@yunvn.com

本站由青云提供云计算服务

运维网--中国最专业的运维工程师交流社区

京ICP备14039699号-1 Copyright © 2012-2018

使用手机软件扫描微信二维码

关注我们可获取更多热点资讯

Good good study day day up !


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


独家合作伙伴: 青云cloud

快速回复 返回顶部 返回列表