设为首页 收藏本站

运维网

查看: 204|回复: 0

[经验分享] 华为——GVRP的应用

[复制链接]

尚未签到

发表于 2018-1-22 13:50:23 | 显示全部楼层 |阅读模式
                                                今天给大家带来一个简单的GVRP的应用,提到GVRP,对于初学者可能并不清楚,GVRP又是实现什么功能的呢?接下来就进入正题。
在实验之前,先给大家简单介绍一下GVRP。
GVRP的概述与功能1.什么是GARP?
GARP(Generic Attribute Registration Protocol)
-称是通用属性注册协议
-协议主要用于一种属性传递扩散的机制
-为处于同一个交换网的交换机提供了一种分发,传播,注册(vlan属性,组播地址等)的手段
2.什么是GVRP?GVRP (Generic VLAN Redistration Protocol)
-是GARP的一种高级应用,用于注册和注销VLAN属性
-通过GVRP协议,一台设备上的VLAN信息会迅速传播到整个交换网
-GVRP实现动态分发,注册和传播VLAN属性,从而达到网络管理员的手工配置量及保证VLAN配置正确的目的。
3.GVRP的注册模式-Normal模式,默认是Normal模式,允许动态和静态VLAN注册,同时会发送静态vlan和动态vlan的申明信息
-Fixed模式,比如某一个端口为Fixed模式,不允许动态vlan注册个注销,且只发送静态vlan的申明信息
-Forbidden模式,比如某一个端口为Forbbid模式,不允许动态vlan在端口上进行注册,同时删除端口上除了vlan1以外的所有vlan,只发送vlan1的申明信息
在了解了GVRP的基本知识后,接下来以一个小实验学习一下GVRP的配置
实验名称:华为——配置GVRP实验目的:让处于同一个交换网的交换机自动学习vlan
实验需求:
三台交换机
实验拓扑:
watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=.jpg
实验步骤:
1.配置GVRP配置思路:&全局开启GVRP&配置链路模式并允许所有vlan通过&端口开启GVRPsw1:
<Huawei>undo terminal monitor  \关闭域名查询
Info: Current terminal monitor is off.
<Huawei>system-view \进入系统视图
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname sw1\修改名字
[sw1]gvrp\全局开启GVRP
Info: GVRP has been enabled.
[sw1]interface GigabitEthernet 0/0/1    \进入端口
[sw1-GigabitEthernet0/0/1]port link-type trunk \配置链路为trunk
[sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan all\允许所有vlan通过
[sw1-GigabitEthernet0/0/1]gvrp\端口开启GVRP
sw1-GigabitEthernet0/0/1]quit\退出

sw2:
<Huawei>undo terminal monitor \关闭域名查询
Info: Current terminal monitor is off.
<Huawei>system-view \进入系统视图
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname sw2\修改名字
[sw2]gvrp \全局开启GVRP
Info: GVRP has been enabled.
[sw2]interface GigabitEthernet 0/0/1\进入端口
[sw2-GigabitEthernet0/0/1]port link-type trunk \配置链路为trunk
[sw2-GigabitEthernet0/0/1]port trunk allow-pass vlan all \允许所有vlan通过**
[sw2-GigabitEthernet0/0/1]gvrp \端口开启GVRP
Info: GVRP has been enabled.
[sw2-GigabitEthernet0/0/1]quit\退出
[sw2]interface GigabitEthernet 0/0/2\进入端口
[sw2-GigabitEthernet0/0/2]port link-type trunk \配置链路为trunk
[sw2-GigabitEthernet0/0/2]port trunk allow-pass vlan all\允许所有vlan通过
[sw2-GigabitEthernet0/0/2]gvrp\端口开启GVRP
Info: GVRP has been enabled.
[sw2-GigabitEthernet0/0/2]quit\退出

sw3:
[Huawei]
<Huawei>undo te mo\关闭域名查询
Info: Current terminal monitor is off.
<Huawei>system-view\进入系统视图
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname sw3\修改名字
[sw3]gvrp \全局开启GVRP
Info: GVRP has been enabled.
[sw3]interface GigabitEthernet 0/0/1    \进入端口
[sw3-GigabitEthernet0/0/1]port link-type trunk  \配置链路为trunk
[sw3-GigabitEthernet0/0/1]port trunk allow-pass vlan all\允许所有vlan通过
[sw3-GigabitEthernet0/0/1]gvrp\端口开启GVRP
Info: GVRP has been enabled.
[sw3-GigabitEthernet0/0/1]quit\退出

2.创建vlansw1:
[sw1]vlan batch 5 10 50\创建vlan 5 10 50
Info: This operation may take a few seconds. Please wait for a moment...done.
3.验证,测试,保存sw1:
watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=.jpg
sw2:
watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=.jpg
sw3:
watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=.jpg
实验总结:在配置过程中,一定要在全局开启GVRP,再在接口开启,否则学习不到。

                                       


运维网声明 1、欢迎大家加入本站运维交流群:群①:263444886群②:197202523群③:485755530群④:201730672群⑤:202807635运维网交流群⑥:281548029
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、其他单位或个人使用、转载或引用本文时必须注明原文的出处
4、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意
5、运维网 - 服务您的运维操作管理专家!
6、联系人Email:admin@yunvn.com 网址:www.iyunv.com

点击关注更多内容
您需要登录后才可以回帖 登录 | 立即注册  

本版积分规则  允许回帖邮件提醒楼主

关注运维网官方微信X

关注运维网官方微信

扫描二维码关注运维网官方微信,最新一手资源尽在官方微信!快快关注我们吧...

扫描微信二维码查看详情

客服 E-mail:kefu@yunvn.com

本站由青云提供云计算服务

运维网--中国最专业的运维工程师交流社区

京ICP备14039699号-1 Copyright © 2012-2018

使用手机软件扫描微信二维码

关注我们可获取更多热点资讯

Good good study day day up !


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


独家合作伙伴: 青云cloud

快速回复 返回顶部 返回列表