设为首页 收藏本站

运维网

查看: 468|回复: 0

[经验分享] 作业

[复制链接]

尚未签到

发表于 2019-1-26 12:25:12 | 显示全部楼层 |阅读模式
  3个压缩包拷贝到root/ntop中:
     Mv *.tar.gz ntop



进入ntop目录将压缩包解压到/usr/src下:
tar fvxz libpcap-0.8.3.tar.gz -C /usr/src
tar fvxz rrdtool-1.1.13.tar.gz -C /usr/src
tar fvxz ntop-3-3.tar.gz -C /usr/src



进入/usr/src目录,进入/libpcap-0.8.3目录,执行文件./configure
会报错:configure: error: Your operating system's lex is insufficient to compile
libpcap.  flex is a lex replacement that has many advantages, including
being able to compile libpcap.  For more information, see
http://www.gnu.org/software/flex/flex.html .


说明缺少必要的软件包flex盘镜像 mount /dev/cdrom /mnt/cdrom

安装flex软件包:yum install flex
安装完成后,再次执行./configure,此时可以正常执行

编译并编译安装:make&&make install


编译报错:
make: yacc:命令未找到
make: *** [grammar.c] 错误 127
需要安装byacc包:yum install byacc
再次编译,此时可以编译成功,libpcap-0.8.3安装完成!

安装rrdtool-1.2.13:

进入目录/usr/src/rrdtool-1.2.13


执行文件./configure –prefix=/usr/local/,rrdtool包安装到Local

报错信息:configure: error: Please fix the library issues listed above and try again.
查找出需要安装的包并通过yum安装:yum install libart-lgpl-devel libxml2-devel pango-devel pango libpng-devel freetype freetype-devel


再次执行./configure –prefix=/usr/local/,此时再次报错:configure: error: Please fix the library issues listed above and try again. 需要安装libart_lgpldevel包:yum install libart_lgpldevel

再次执行./configure-prefix=/usr/local,可以成功执性
编译并编译安装:make&&make install

安装ntop-3.3
进入目录/usr/src/ntop-3.3
Ntop中有自动执行脚本,自动生成文件并自动配置。并将mysql屏蔽
执行:./autogen.sh –disable-mysql  报错:
     1. Testing gnu tools....

You must have libtool installed to compile ntop.
Download the appropriate package for your distribution, or get the
source tarball from ftp://ftp.gnu.org/pub/gnu/libtool
     We require version 1.4 or higher
     We recommend version 1.5 or higher

You must have automake installed to compile ntop.
Download the appropriate package for your distribution, or get the
source tarball from ftp://ftp.gnu.org/pub/gnu/automake
     We recommend version 1.6.3 or higher

You must have autoconf installed to compile autogen.sh.
Download the appropriate package for your distribution, or get the
source tarball from ftp://ftp.gnu.org/pub/gnu/autoconf
     We recommend version 2.53 or higher

需要安装libtool包:yum install libtool
再次执行./autogen.sh --disable-mysql 报错:
    configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
缺失C++编译库,安装c++编译库文件:yum install gcc-c++
再次执行./autogen.sh --disable-mysql
成功!

编译并编译安装:make&&make install
安装完成!




运维网声明 1、欢迎大家加入本站运维交流群:群①:263444886群②:197202523群③:485755530群④:201730672群⑤:202807635运维网交流群⑥:281548029
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、其他单位或个人使用、转载或引用本文时必须注明原文的出处
4、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意
5、运维网 - 服务您的运维操作管理专家!
6、联系人Email:admin@yunvn.com 网址:www.iyunv.com

点击关注更多内容
您需要登录后才可以回帖 登录 | 立即注册  

本版积分规则  允许回帖邮件提醒楼主

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服 E-mail:kefu@yunvn.com

本站由青云提供云计算服务

运维网--中国最专业的运维工程师交流社区

京ICP备14039699号-1 Copyright © 2012-2018

使用手机软件扫描微信二维码

关注我们可获取更多热点资讯

Good good study day day up !


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


独家合作伙伴: 青云cloud

快速回复 返回顶部 返回列表